Contact Moveworks Support                                                                                                         
Access Issue with EXI Dashboards
Incident Report for Moveworks
Resolved
This incident has been resolved as of 7:58am pacific time.
Posted Nov 14, 2022 - 15:58 UTC
Update
The team is still investigating the issue.
Posted Nov 14, 2022 - 15:51 UTC
Investigating
We are currently investigating a 504 error affecting access to the EXI dashboard.
Posted Nov 14, 2022 - 15:06 UTC
This incident affected: Employee Experience Insights.