Contact Moveworks Support                                                                                                         

Moveworks Setup & Agent Studio Error Handling Degradation

Incident Report for Moveworks

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 23:00 UTC

Monitoring

We have implemented a fix and are currently monitoring the results. We apologize for the inconvenience caused and appreciate your patience during this time. Thank you for your understanding.
Posted Jul 02, 2025 - 21:12 UTC

Identified

We have identified an issue in MW Setup and Agent Studio where error handling is broken. As a result, invalid configuration changes lead to failures without displaying valid error messages. Additionally, certain configuration screens are presenting the error message: "Cannot destructure property 'viewUpdateActionResponse' of '(intermediate value)' as it is undefined." when viewed.
Posted Jul 02, 2025 - 20:29 UTC
This incident affected: Creator Studio (Paths Workspace, Queries Workspace, Events Workspace, Plugins Workspace) and My Moveworks Portal (Moveworks Setup).