Contact Moveworks Support                                                                                                         
Decrease in Copilot Channel Resolver reachouts
Incident Report for Moveworks
Postmortem

The root cause was an assumption made in the guardrails used by Moveworks Copilot Channel Resolver to prevent reaching out to users with answers that are not grounded in customer knowledge content and automations.

On November 4, 2024, we launched multi-plugin response, a feature that allows Moveworks Copilot to call multiple plugins in parallel and integrate the responses into a single answer.

Multi-plugin response introduced a new plugin response behavior pattern that occasionally broke the assumption above made by Channel Resolver guardrails.

The decrease in reachouts was corrected by deploying an update to the guardrails.

Posted Nov 27, 2024 - 15:58 UTC

Resolved
We would like to inform you that we have identified and resolved a recent issue affecting Channel Resolver in Moveworks Copilot. Moveworks Copilot was reaching out with resolutions to posts in channels for which Channel Resolver is enabled 10-20% less often than expected. This decrease led to missed opportunities to help customer employees with issues for which relevant resources to answer the query were available. Fixes were deployed to all customers between November 22 and November 25.
Posted Nov 04, 2024 - 18:00 UTC