Contact Moveworks Support                                                                                                         

UI Issue with Advanced Filters in “Select Audience” – Employee Communications

Incident Report for Moveworks

Resolved

This issue has been resolved now. Thank you for your patience while we worked on this. We apologize for any inconvenience this may have caused.
Posted Jul 01, 2025 - 12:15 UTC

Identified

We are currently experiencing a UI issue in the Select Audience section of Employee Comms. When using advanced filters, the interface may incorrectly appear as if your selections have not been applied. However, please note that the selections are retained on the backend.

To proceed, kindly make your desired selections and click “Apply Condition” — the audience will be correctly selected despite the visual discrepancy.

We have identified the root cause of this UI inconsistency and are actively working on a fix. Thank you for your patience and understanding.
Posted Jul 01, 2025 - 10:48 UTC
This incident affected: Employee Communications.