Contact Moveworks Support                                                                                                         
Ticket processing degradation
Incident Report for Moveworks
Resolved
This incident has been resolved as of 3:45 PM PST.
Posted Feb 28, 2024 - 23:47 UTC
Investigating
We're currently investigating an issue affecting some users. These users may experience failures when performing actions related to tickets. We appreciate your patience and understanding as we work to resolve this issue promptly.
Posted Feb 28, 2024 - 23:11 UTC
This incident affected: Concierge.