Contact Moveworks Support                                                                                                         
Campaign Details Viewing Error
Incident Report for Moveworks
Resolved
This incident has been resolved.
Posted Nov 09, 2023 - 06:48 UTC
Monitoring
A fix has been implemented and we are no longer encountering the error, we will continue to monitor it.
Posted Nov 09, 2023 - 06:13 UTC
Investigating
We are currently investigating an issue wherein users may encounter "Oops! Some data seems to be missing. Use the support widget to report this issue or try again later error" while viewing the campaign details. We apologize for the inconvenience this may cause and appreciate your patience while we work towards a resolution.
Posted Nov 09, 2023 - 05:19 UTC
This incident affected: Control Center (Employee Communications).