Contact Moveworks Support                                                                                                         
Copilot performance degradation
Incident Report for Moveworks
Resolved
The issue with Copilot action receipts not being received has been fixed as of 1 PM PST. We appreciate your patience while we resolved this.
Posted Aug 29, 2024 - 20:38 UTC
Identified
We have identified an issue that is causing degraded performance in Copilot actions. Our team is actively investigating the matter to promptly resolve the issue.

We appreciate your patience and understanding as we work towards a swift resolution.
Posted Aug 29, 2024 - 20:17 UTC
This incident affected: Concierge.