Contact Moveworks Support                                                                                                         
Copilot Insights outage
Incident Report for Moveworks
Resolved
This incident has been resolved. Users should now be able to view data in Copilot Insights dashboards as expected.
Posted May 31, 2024 - 08:05 UTC
Identified
We have identified an issue impacting the users ability to view data within the Copilot Insights Dashboards. We are actively working towards a resolution to restore access as quickly as possible. We sincerely appreciate your patience and understanding as we work towards resolving this issue.
Posted May 31, 2024 - 07:52 UTC
This incident affected: Copilot Insights.