Contact Moveworks Support                                                                                                         

Ticket notification degradation

Incident Report for Moveworks

Resolved

We're pleased to inform you that the incident has been resolved. All users should now be receiving ticket notifications without issue. Thank you for your patience while we worked to address this matter.
Posted Jun 21, 2024 - 16:03 UTC

Identified

We're currently addressing an issue where some users may not be receiving ticket notifications as expected. We apologize for any inconvenience this may cause and appreciate your patience as we work to resolve the matter promptly.
Posted Jun 21, 2024 - 15:36 UTC
This incident affected: Concierge.