Moveworks Setup — Logs Delayed or Not Loading

Incident Report for Moveworks

Resolved

Our engineering team has resolved the issue. Logs in Moveworks Setup are now loading as expected. Thank you for your patience, and apologies again for the inconvenience.
Posted Jul 07, 2026 - 16:17 UTC

Investigating

We're aware of an issue affecting Moveworks Setup where logs are currently not loading, and our team is actively investigating. We apologize for the inconvenience.

Impacted Region: US
Posted Jul 07, 2026 - 15:39 UTC
This incident affected: My Moveworks Portal (Moveworks Setup).