Contact Moveworks Support                                                                                                         

Brief Me Outage

Incident Report for Moveworks

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 18:25 UTC

Identified

The issue has been identified and a fix is being implemented.

Impacted Regions: US, EU, CA, AU
Posted Jun 10, 2025 - 17:19 UTC

Investigating

We have identified an issue where users are currently unable to use the "Brief Me" feature in AI Assistant. Our team is actively investigating the problem and will keep you updated as we make progress. We appreciate your patience and understanding during this time.
Posted Jun 10, 2025 - 16:46 UTC
This incident affected: Productivity Boost (Brief Me).