Contact Moveworks Support                                                                                                         

AI Assistant Response Quality Degradation

Incident Report for Moveworks

Resolved

This incident has been resolved. Thank you for your patience.

Duration: 7:20 AM PST - 8:18 AM PST
Impacted Region: US
Posted Aug 13, 2025 - 16:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2025 - 15:23 UTC

Investigating

We are currently investigating an issue affecting AI Assistant, which is causing slow response times and timeouts for some users. We understand the impact this has on your operations and are working diligently to resolve the issue as quickly as possible. We will provide updates as soon as more information is available. Thank you for your patience and understanding.
Posted Aug 13, 2025 - 15:06 UTC
This incident affected: Moveworks AI Assistant.