Contact Moveworks Support                                                                                                         
Slowness in bot responses
Incident Report for Moveworks
Resolved
This incident has been resolved as of 2:45 PM PST.
Posted Feb 16, 2024 - 22:56 UTC
Investigating
We are currently investigating an issue where some users may be experiencing slower than usual responses from our bot. We understand the impact this may have on your experience and we are working diligently to resolve this issue as quickly as possible.
We appreciate your patience and understanding during this time. We will provide updates as more information becomes available.
Posted Feb 16, 2024 - 22:04 UTC