Contact Moveworks Support                                                                                                         

Events degradation

Incident Report for Moveworks

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 21:46 UTC

Identified

We are actively investigating an issue where some users are not receiving event notifications. We apologize for the inconvenience this may cause and will keep you posted on our findings.
Posted Feb 20, 2025 - 21:07 UTC
This incident affected: Creator Studio (Events Workspace).